Self Compiled Kernel Stops Booting in Ubuntu 14.04 [Fixed]

After switching from Ubuntu 12.04 to 14.04 I've noticed my self compiled kernels would not boot well. There was always an error that a device (root / and swap) could not be mounted. Also I could no longer mount removable devices, such as USB sticks.

This is due to changes in the boot process with the new version of Ubuntu. The issue disappears if root is mounted rewrite by default. Hence you should change the root=/dev/... ro to root=/dev/... rw. Actually just booting once like this seems to have fixed my problem permanently, i.e. now I can boot with ro again and I have no issue.
Another possible reason could be a problem during fsck (fix).

Ubuntu now also requires the kernel automounter support version 4. The config entry is CONFIG_AUTOFS4_FS=m. Then everything worked again.

Fix for blank screen or black display after resume with open source radeon drivers in Xorg

The bug was reported in detail here. The fix comes in two ways:

1. For just echo mem > /sys/power/state to work, use the kernel boot parameters nomodeset acpi_sleep=s3_bios,s3_mode
-> You have to test which of the s3_bios or s3_mode settings work for you. You may also use number 1, 2, and 3 in /proc/sys/kernel/acpi_video_flags instead to change the setting at run time.

2. For pm-suspend to work (e.g. *Ubuntu) you need to create a file
/etc/pm/config.d/radeon  which contains  QUIRK_S3_BIOS="true"  QUIRK_S3_MODE="true"
3. To have working mode setting, load the radeon module with modeset=1, by creating a file
"options radeon modeset=1"